RSU Map File Creation Work Instructions
Objective
This procedure outlines the steps taken to produce an SAE J2735 compliant MAP file for use with the Spectra RSU. J2735 messages are encoded using unaligned packed encoding (UPER) rules when transmitted from the roadside unit based on the 2016 standard’s requirements. Due to this encoding scheme, the MAP must be created using the USDOT Connected Vehicles Tools ISD Message Creator utility to encode MAP data. This procedure assumes user familiarity with traffic control terminology, intersection geometry and layout.
Material Requirements
1. Windows PC with internet connection and web browser (Chrome or Firefox)
2. Customer intersection location
3. Intersection diagram or equivalent
4. Google Earth Pro
Basic Map File Creation
1. Open the USDOT Connected Vehicles Tools website: https://webapp.connectedvcs.com/
2. Click on View Tool to open the ISD Message Creator.
[image: ]
3. Click on File → New Parent Map to start a new parent map.
[image: ]
4. Enter an address near the intersection location in the search bar.
[image: ]
5. Use the middle mouse button to move the map view and the mouse wheel to zoom in and out of the map. Center the view on the intersection and click on the Builder icon. 
[image: ]
6. Place the Reference Point Marker in the center of the intersection.
[image: ]
7. The Reference Point Configuration menu should appear upon placing the Reference Point Marker, if the menu does not appear left click on the Reference Point Marker to bring it up.
[image: ]
8. In the Type field set the type to (1) Signal and click on Done.
[image: ]
9. Open Google Earth Pro and navigate to the same location for the intersection in the ISD Message Creator.
10. Using the ruler tool, measure each nominal lane width in centimeters for every lane in the intersection and calculate the average lane width.
[image: ]  [image: ]
11. Return to the ISD Message Creator, in the Reference Point Configuration menu, enter the average lane width (rounded up, whole integer) in the Master Lane Width field.
[image: ]
12. Place the Verified Point Marker in an accessible and measurable location such as the traffic cabinet or measured on-site field survey point if available.
[image: ]
13. The Verified Point Configuration menu should appear upon placing the Verified Point Marker, if the menu does not appear left click on the Reference Point Marker to bring it up.
[image: ]
14. If the Verified Latitude, Longitude and Elevation values are available from on-site field surveys enter them in the noted fields, otherwise click on Done.
15. Click on File → Save and to save the Parent Map.
[image: ]
16. When prompted to enter a revision number enter 0, click on Continue (Note: Do not hit the Enter key, make sure to click Continue) and save the Parent Map to the local disk.
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17. Click on File New → Child Map to start building the Child Map.
[image: ]
18. Click OK on the file dialog notice to open the Parent Map; locate, select and open the Parent Map created in the previous steps.
[image: ]
19. Click on the Draw Approaches button in the bottom left corner to select the draw approach boxes.
[image: ]
20. Draw Approach boxes across every ingress and egress approach relative to the intersection over the stop bar and across every lane as shown.
[image: ]
21. Use the Edit Approaches button to rotate, expand or contract the Approach boxes as needed.
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22. Starting the with the northmost approach, left click on each Approach box to open the Approach Configuration menu.
[image: ]
23. Under Approach Type select Ingress if the lanes are directed into the intersection and Egress if the lanes are directed out of the intersection; select the lowest Approach ID available starting at 01 then press Done.
24. Repeat the previous two steps for all approaches in a clockwise order until all approach configurations have been set.
25. Select the Measure tool.
[image: ]
26. Left click on the stop bar of an approach, measure the distance from the stop bar to at least 180 meters away using the measured distance on the upper right, note the location with a landmark.
[image: ] [image: ]
27. Left click on the Draw Lanes button.
[image: ]
28. Left click on the center of the lane at the stop bar and move the mouse cursor away to begin drawing lanes.
[image: ]
29. Use the middle mouse button to drag the view out to the measured landmark, left click on the center of the lane as needed to remain in the center.
30. Once the lane is at the desired landmark, double click on the desired endpoint of the lane to terminate the lane.
[image: ]
31. Left click on the Edit Lanes button and select the drawn lane to edit as needed, left click and drag the opaque midpoints to add nodes and use the DELETE key to delete nodes.
[image: ]
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32. Repeat the process for other individual lanes of the approach, for dedicated right and left turn lanes span the entirety of the lanes up to the initial lane markers, until completed as shown (Rotated 90° CW).
[image: ]
33. To draw the egress lanes, click on the Draw Lanes button, click on the center of the egress lane within the approach box, draw the egress lane to at least the same length as the left turn lane, and double click on the endpoint to terminate the lane; repeat this process for all egress lanes in the approach box until completed as shown (Rotated 90° CW).
[image: ]
34. Repeat the process of drawing lanes until all lanes of the intersection are completely drawn as shown.
[image: ]
35. Click on the starting point of the left-most lane in the northern ingress approach box to open the Lane Configuration menu.
[image: ]
36. Left click on the Builder Menu to open the Lane tab.
[image: ]
37. Drag and drop the allowed maneuvers from the appropriate icons in the Lane tab to the Lane Attributes box in the Lane Configuration menu; refer to the intersection diagram, lane markings, and visible signage (via Google Earth) to determine the allowed maneuvers.
[image: ]
38. In the Lane Type field select Vehicle, in the Type Attributes field select (0) Vehicle Revocable Lane, in the Shared With field select (3) Individual Motorized (4) Bus (5) Taxi, and in the Lane Number select the lowest available lane number starting with 01; click on Done when finished.
[image: ] [image: ] [image: ]
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39. Repeat this process for all remaining lanes in the intersection, once completed Lane Numbers will be visible at the starting nodes for each lane as shown.
[image: ]
40. Click on the node designated 1 again to open the Lane Configuration menu and click on the Connections tab.
[image: ]
41. Left click on the Builder Menu to open the Lane tab.
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42. Open the site-specific intersection diagram such as the diagram shown below.
[image: ]
43. Using the intersection diagram as a reference, enter the destination lane number in the “To” Lane Number field and the phase number associated with the movement in the Signal Group ID field.
[image: ]
44. Drag and drop the allowed maneuvers for the given phase and lane number from the Lane tab of the Builder menu to the Allowed Maneuvers Box in the Connections Tab.
[image: ]
45. Use the + button in the Connections tab to add additional connections and repeat the process as needed, click on Done when finished.
[image: ]
46. Click on node designated 1 again, blue arrows will be visible to display established connections.
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47. Repeat this process for every ingress lane in the intersection, egress lanes do not need connections.
48. Click on Tools → Toggle Lane Widths to show the projected lane widths for every lane in the intersection.
[image: ]
49. Inspect every lane overlay for overlapping lane widths and if possible, move lane nodes using the Edit Lanes button until the overlapping lane widths are cleared. Click on Tools → Toggle Lane Widths twice to update the lane overlay positions.
[image: ]
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50. If the lane widths shown in the overlays exceed the lane markings on the map, use the Measure tool to measure the width of the affected lanes.
[image: ]
51. Click on each of the affected lane nodes and adjust the widths by entering the difference between the measured lane width and the master lane width into the Lane Width Delta field. For example, if the measured lane width is 300cm and the master lane width is 366cm, enter the value “-66” into the field. Click on Done when finished.
[image: ] [image: ]

52. Save the Child Map file using File → Save.
[image: ]
53. When prompted enter the revision number starting with 0 (Click Continue, do not press “Enter”).
[image: ]
54. Save the Child Map to the same directory on the local disk as the Parent Map, increment the revision number by 1 whenever making significant edits and revisions to the Child Map.
55. Click on Tools → Encoder to open the Message Encoder.
[image: ]
56. Set the Message Type to Frame+Map and the Node Offsets to Standard (32 bit). Leave the Enable Elevation checkbox checked.
[image: ] [image: ]
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57. Click on the Encode button, ignore the warning for the SPaT message as this instruction is for building MAP messages, if there are no errors the UPER Hex string will populate as shown.
[image: ]
58. If the message size exceeds 1400 bytes the RSU will not be able to support the payload size, reduce the size by deleting excess points in lanes.
59. Double-click on the UPER Hex string output to select it. Press Ctrl-C to copy the string.
[image: ]
60. Create a MAP Active Message text file example referenced in Appendix A using the file naming convention map16_0x8002_<intID>.txt, replacing <intID> with the Intersection ID from the Parent Map.
61. In the Payload1 field, remove the entire UPER Hex string in the file (if any) then paste the UPER Hex string copied from the Encoder into the file after = sign. Save and close the file when completed.


Appendix A – MAP Active Message Text File Example
Version=0.7
Type=MAP16
PSID=0x8002
Priority=7
TxMode=ALT
TxChannel=172
TxInterval=2
DeliveryStart=04/16/2017, 01:01
DeliveryStop=11/30/2038, 23:50
Signature=False
Encryption=False
Payload1=


Appendix B – Site Specific Use Cases
This section covers site specific features not covered in the basic intersection MAP file setup.
Channelized Turns
Channelized right turn lanes provide free-flow right turn movements at intersections. These lane types shall be drawn with the Approach box at the exit of the turn and with the lanes drawn from the Approach box to the to the start of the turn. Since the lane is free-flowing, the Signal Group ID shall be set to 255 to indicate a constant permissive movement state. If the channelized right turn lane exits to a new lane, then draw an egress Approach box with egress lane and connect the channelized right turn lane to that lane. Otherwise, if the lane exits to merge with an existing adjacent egress lane, then connect the channelized right turn lane to that lane. If the signage at the channelized right turn requires the vehicle to yield before merging or proceeding, add the “Yield” Allowed Manuever onto the Lane Attributes field and to the Connections tab in the Lane Configuration menu of the lane.

[image: ]

[image: ]

[image: ]
Overlaps
Overlaps allows movements to utilize multiple phases. A common form of overlap services both right turn movements from a main street with left turn movements from a side street. To implement overlaps in the MAP file, add the Signal Group ID of the active left turn into the Connections tab of the overlapping right turn and include the same Allowed Maneuvers as the main street’s active phase. In the example shown below, the northbound left turn from the side street is active at Phase 7, while the eastbound right turn is normally active at Phase 6. Since the eastbound right turn also functions as an overlap, the turn is also active during Phase 7 as shown in the Connections tab.
[image: ]
[image: ]
Flashing Yellow Arrows
Flashing yellow arrows provide a form of protect-permissive left turn movements where a protected green arrow is followed by a permissive flashing yellow arrow at the turn. They may also be interpreted and implemented as an overlap using the Signal Group ID of the conflicting through movement’s phase and the “Yield” Allowed Maneuver. In the example shown below, the southbound left turn is a flashing yellow arrow whose protected phase is Phase 1 and permissive phase is Phase 2, the same phase as the conflicting northbound through movement with the additional “Yield” restriction as shown.
[image: ]
[image: ]


Unmarked Roads (Stencils)
In certain cases, the ISD Message Creator will display aerial photography of an intersection that has not yet been built at the time the photos were taken. In these scenarios, a stencil can be created and imported from Google Earth, if the aerial photography is current, to provide adequate waypoints to recreate the lanes in the ISD Message Creator. Perform the following steps to implement stencils in the MAP design.
1. While keeping the intersection in the ISD Message Creator, open Google Earth Pro and navigate to the same intersection.

[image: ]

[image: ]

2. In Google Earth Pro, expand the Places tab, select My Places and click on Add → New Folder and name the folder with the intersection. Click OK when done.

[bookmark: _GoBack][image: ][image: ][image: ]
3. Click on the Add Path button and draw a path along the center of each lane required for the stencil.
[image: ]
[image: ]
4. Select the folder created for the intersection then click on File → Save → Save Place As… and to save the stencil.

[image: ]  [image: ]
5. Set the file format to KML and save the stencil to the local disk.
[image: ]
6. Return to the ISD Message Creator and click on File → Open Stencil to open the previously saved stencil.
[image: ]
7. The stencil should now overlay across the unbuilt roadway. Click on File → Delete Stencil after drawing lanes in ISD Creator to remove the stencil when no longer needed.
[image: ]
[image: ]
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